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Foreword

 In December of  2013 I started a project that had grown and taken hold on me for years.
Would it be possible to animate our own backyard telescopic images of Jupiter, making them completely 
immersive and showing the evolution of Jupiters storm systems for a continuous period of more than 3 
month?
I had a very vague idea of how this could be done but as a photographer and digital artist I am used to 
�nding solutions to whatever imaging problem that might arise, relaying mostly on Photoshop, a software I 
have been using since the �rst versions in the early 1990-ies.

Had I been more lucid about the problems I would encounter during this project, it would probably just 
have remained a dream.
I spent 6 month and thousands of hours on the project that I named “Voyager-3 Project”, making a parallell 
to the iconic probes of the 1970-ies that are still in operation and now transmitting from the interstellar 
space.

In 2015 I made a short follow up animation showing the proper rotation of the GRS. In order to have 
pictures taken more frequently, we extended the cooperation to our Australian and Dutch friends.

And �naly in 2016 I got into the Mission Juno Pro-Am collaboration thanks to Glenn Orton and decided to 
do a full scale animation using almost 1,000 images taken in 2015 by 90 skilled planetary photographers 
from all around the world. One full year and thousands of hours of hard labour later, I released the a new 
video called “A journey to Jupiter”.

These 3 productions were well received by the amateur and professional astronomical communities but 
they involved so much hard labour and were too time consuming to be used on a regular basis in creating 
animations.

 This last year, I have tried to streamline the work�ow and looked for techniques and shortcuts that 
would enable us to make animations of the same quality but in a fraction of the time and that was the aim 
of my presentation at Europlanet 2018 in London.

For these animation projects to be successfull, there are some guidelines that should be followed and we 
need to be consequent in every step in order to get a correct and even result.

With almost 100 photographers involved, there are almost as many variations to the look of the images they 
produce. Some are of course of very high quality in every respect while others may be too dark or too bright 
or even overexposed in the highlights, with hues ranging through all the colors of the spectrum. 
These images will simply not merge seamlessly into a smooth animation so one of the single tasks that has 
been the most time consuming in the projects mentioned above was to correct the 1,000 images to a 
common standard in respect of color, contrast, and sharpness. 

I hope that we can setup a network and let the photographers do the processing and the Winjupos map-
ping of their own images to a common standard before uploading them to a database that we will set up in 
the near future.
This would be the single biggest bene�t allowing any of us in a near future to do animations on a regular 
basis. And it will only take minutes or hours, not weeks or month.

Besides the beauty of seeing the cloud belts of Jupiter swirl and spin, I’m sure it will prove to be a new and 
valuable tool for analysis and to understand the evolution of the storm systems.



Step 1 - Image acquisition and preprocessing

Should North be presented up or down? This is a topic of much discussion but I have opted for South up and the 
planet presented as horizontaly as possible.

Acquire the �les only as plain RGB , no L-RGB, IR-RGB or IRGB.

You may derotate them over a period but this is not absolutely necessary. For an animation project it might be 
preferable to make separate images of the beginning and end of a session that will result in a better total coverage.

Try to take images also at odd hours when not everybody else is out photographing the same side of Jupiter.
This will be helpfull in increasing the coverage of the maps. Don’t throw away the less than perfect images, they 
are needed for the continuity and will integrate seamlessly with the better ones.

Don’t crop out the moons from your images as they help to make a more precise mapping in Winjupos.
They will be removed later from the Winjupos projections before being stacked and stitched.
 
Stack your images and process them to a normalised standard, see the examples bellow.
Make sure to keep a good histogram reading so no details are burnt out and keep the limbs su�cently bright so 
they can be easily identi�ed. If they are very dark, it may result in mapping errors in Winjupos.

Name the �les in the format jYYYY-MM-DD_HH-MM-SS_RGB_xxx (xxx being your initials with 2 or 3 letters). In this 
way they will be correctly named for Winjupos and displayed in chronological order. The timing is measured as the 
middle of the captured sequence.

 

4 images taken by Anthony Wesley, Chistopher Go, Clyde Foster and Damian Peach that are good examples of
images that will work very well when combined and merged into a single map.



Step 2 - Mapping in Winjupos

You are probably more knowledgeable about the mapping in Winjupos than I am as I only work on a Mac and have 
received some helping hands when it comes to this stage, so I will not give any advice about how to perform the 
mappings, just some useful guidelines.

Map the images in Winjupos as Longitudes in System 2, planetographic latitudes, Cylindrical projections. Make the 
image area itself 1800 x 536 pixels.
This is a good scale as 1800 pixels correspond to the full 360° coverage meaning that 5 pixels correspond to 1° 
making measurements in the Photoshop �les very easy to perform.

The 4 images on the left by Damian Peach and Tizziano Olivetti are taken approximately 2,5 hours apart. 
To the right, the corresponding cylindrical projections represent a translation along the x-axis of longitudes.
The red line illustrates how the GRS remains at the same longitude when the images are rendered in Winjupos.
The �gure at the bottom represents a complete map corresponding to the addition of the 4 projections above.



Step 3 - Preparing the maps for stacking
and stitching in Photoshop

Open the maps in Photoshop and crop them to the exact image area of 1800 x 536 pixels using the Rectangular 
Marquee Tool,   Style: Fixed Size,   With:1800 pix,   Height: 536 pix.

Go to Image > Crop in the menu to only keep the image area.

Select the Magic Wand Tool with the settings Tolerance: 20 (works most of the time), uncheck Anti-alias,
and check Continuous. Click anywhere in the white area that will then become selected.

The layer is locked by default. Double click on it in the Layer Palette to unlock it and make it a �oating layer. 
Press the Delete/Backspace key on the keyboard to remove the selected white area and make it transparent.
Save the images to a new folder in a format that accepts transparency like PSD, TIFF or PNG.



Step 4 - Stacking and stitching 

You should now have a folder with all your maps that are almost ready to be stacked and stitched together.
An important last step is to darken any artifact that can appear on the limb. They generaly result from camera �aws 
or sharpening and become overly broad by the stretching in the Winjupos mapping.

 

We are now ready for the stacking. It is important to proceed in a chronological order from the oldest images to 
the most recent ones. 
Use just enough �les to get a good overlap and that will cover the whole 360° surface. At least 4 or 5 will be 
needed but sometimes more depending on the quality of the images.
The best way to do this is to go to Files > Scripts > Load �les into Stacks, click on Browse and select the �les you 
want to open.

They will automatically appear as layers in a new document and retain their original name (1).
Put a black layer at the top of the layer stack (2). 
Select all the layers (3). Go to Layers > Arrange > Reverse. This will reverse the order so the oldest map is at the 
bottom and the most recent is at the top of the stack (4).



Step 4 - Stacking and stitching - continued 

The image bellow shows what your map should look like at this stage.
You can blink between consecutive layers to make sure that they are well registered. 
If the mapping was done correctly in Winjupos there should be no problem.

Select all the image layers in the Layer Palette and change the blending mode to Lighten

The images will automatically blend into a an almost perfect 360° map.

You should �atten the layers and save the map into a new folder. Proceed to the next set of images to stack. Ideally 
the mean time between 2 �nished maps should be no more than 2 to 4 earth days corresponding to 5-10 revolu-
tions of Jupiter.
You can bring all the �nished maps into a video editor to make an animation or you can make an animated gif from 
within Photoshop.

Many of the steps described untill now can be scripted into Photoshop Actions and performed automatically.



Step 5 - Polar Projections 

South Polar projection.

Transforming a cylindrical map into a polar projection is extremely easy in Photoshop, just follow the steps bellow:
Open a �nished 360° map and upscale it to 200 % so it becomes 3600 x 1072 pixels in size.

Go to the Filter Menu and choose Distort > Spherize and then Mode: Vertical Only
Here you have got several choices. Use Amount -80 if you just want the render the polar view just to be aestethical. 
If you want to be able to perform measurements then you should choose Amount -100 as it will render the 
latitudes as equidistant circles. For example, the distance between 20° and 30° will be the same as between 80° and 
90°.

If you use the above map, the polar projection will display from Pole to Pole. I am quite found of this rendering as it 
still lets you follow all the cloudbelts around the whole planet but it might not be considered acceptable for some 
people. For a rendering from Pole to Equator, just �ll the lower half of the map with black and proceed the same 
way.



Step 5 - Polar Projections - Continued 

Extend the Canvas size downwards with black into a square of 3600 x 3600 pixels by choosing Image > Canvas Size 
in the Menu

Go to Filter > Distort > Polar Coordinates and choose Rectangular to Polar.

Crop the image to a nice working size, for example 1200 x 1200 pixels, as there is a lot of black surrounding the 
image. If you have chosen to display from Pole to Equator, the projection will look like the one bellow to the right.



Step 5 - Polar Projections - Continued 

North Polar projection.

To make a North Polar Projection, you just start by rotating the initial map by 180° and you proceed exactly the 
same way as for the South Polar Projection.
All these steps can easily be put into a Photoshop Action and it can transform a folder with hundreds of maps in a 
matter of a few minutes.

Bellow are the results of the South Polar Projection and the North Polar Projection, from Pole to Pole.



Step 6 - Beyond the Equatorial and Polar Maps 

If you carefully follow the steps described in this paper, anybody should be able to produce high quality animated 
equatorial and polar maps of Jupiter in a relatively short time.

The next step is to bring these maps back to the real shape of Jupiter by projecting them on an ellipsoid.
I found that StarryNight Pro+ from Simulation Curriculum, https://starrynight.com/ProPlus7/index.html let you 
import your own maps on any solar system body.
To do this you need to import your �nished maps into Photoshop and use the �lter Distort > Spherize with the 
option Vertical Only, amount: -100. Save them to a new folder

Open StarryNight Pro+ vers. 6 or 7, zoom in on Jupiter and Ctrl click or right mouse click (both are Mac commands) 
on the planet to open the contextual menu and choose Surface Image Model > Add / Edit and in the next step: 
Add Image. Browse your folder and chose the map you want to apply on Jupiter.



Step 6 - Beyond the Equatorial and Polar Maps - Continued

So what are the possible applications when the maps are imported and reprojected on Jupiter?
You have for example the possibility to move out in space and simulate a �yby over the poles as I did in “A Journey 
to Jupiter”.
Although the images are all taken from earth you can visualize close-up views of Jupiter from any direction in 
space.
To make animations on the other hand is extremely labour intensive as you have to shift map, shift the time and 
the position in space, take a screen capture and repeat for the next view until you are �nished with the sequence.
It is a very precise stop-motion technique and I have found no way to automate or speed up these steps that can 
still take days to perform.

Another application was to simulate the views captured by JunoCam during its 6th perijove on the 19th of May 
2017. The main di�culty was that the images from Juno got a higher and higher de�nition the closer it got to 
Jupiter while the same views in the images taken from earth were smaler and smaler crops and very di�cult to 
identify in the amateur images.

The upper row shows the original views from JunoCam and the lower row represent the corresponding images 
mapped in StarryNightPro.
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